WordPress3.6にしたら、1.10は1.2より古いとか言い出した。

  • このエントリーをはてなブックマークに追加
  • 0

WordPressを3.6にアップグレードしたところ、以下のようなエラーが出だした。
WordPress3.6にしたらエラー出る

「blockUI requires jQuery v1.2.3 or later! You are using v1.10.2」だと?何言ってんだ。
まぁ、とりあえずダイアログは出るが、使えてはいる。

どうも、jQueryのblockUIだか、それを使ってるコードのほうだか分からんが、バージョンチェックをしくじっているらしい。このSupportの記事にあるように、バージョンチェックで「1.2以上」としたいのにもかかわらず、今の「1.10」を、「最後の0を外して」比較してしまっているらしく、「1.10」は「1.2」より古いという誤った判断の元、このダイアログが出ているらしい。
Supportの記事に方には解決策が出ているっぽいが、英語を読めないし複雑そうなのでやめた。早くバージョンアップして解決してくれ!

何か、昔Flash Playerのバージョンが9から10に上がった時も同じようなエラーが出ていたような気がする。人は過ちを繰り返さずにはいられない生き物なんだな。

スポンサーリンク
スポンサーリンク
  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク
スポンサーリンク